Degraded performance on Calls on Africa's Talking phone numbers

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 14:53 EAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2025 - 14:53 EAT

Investigating

We have identified that might not be coming through or going out. We have raised a case with Africa's Talking to help resolve the issue.
Posted Mar 13, 2025 - 08:19 EAT
This incident affected: Voice.