[AFRICA'STALKING] Incoming Calls Not Appearing On The Phone

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 05:12 EAT

Update

We are continuing to work on a fix for this issue.
Posted Jun 30, 2025 - 05:12 EAT

Identified

We are currently awaiting a fix from Africa's Talking.

We continue to capture the incoming call and are creating CallLogs and Tickets on our system. Once we are alerted that a fix has been applied, we will add a patch to update the calls on the CTI.
Posted Jun 28, 2025 - 16:28 EAT
This incident affected: Voice, Zendesk Phone, Odoo Phone, Salesforce Phone, Freshdesk Phone, and Zoho Phone.