Phone Network Disruption

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted May 08, 2026 - 16:39 EAT

Investigating

We have alerted Africa's Talking who are resolving the issue.
Posted May 08, 2026 - 15:28 EAT
This incident affected: Voice.