Network Advisory: Issue with Outgoing Calls on Africa’s Talking Network

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 14:54 EAT

Investigating

We are currently experiencing an issue affecting outgoing calls on the Africa’s Talking network. The disruption appears to be originating from Safaricom’s side, and Africa’s Talking is actively engaging them to resolve the matter.

We will keep you updated as soon as normal service is restored.
Posted Nov 28, 2025 - 11:40 EAT
This incident affected: Voice.