Phone Network Disruption

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted May 05, 2026 - 16:02 EAT

Update

We are continuing to investigate this issue.
Posted May 05, 2026 - 16:02 EAT

Investigating

We have alerted Africa's Talking to resolve the network error.
Posted May 05, 2026 - 14:44 EAT
This incident affected: Voice.