Phone Takes a few minutes to connect

Incident Report for Helloduty

Resolved

The phone takes a few minutes (2 - 3 minutes) to connect to the network when the phone is freshly opened, but once connected, calls should be handled seamlessly.
Posted Mar 24, 2025 - 09:48 EAT

Investigating

We are currently investigating the issue.
Posted Mar 24, 2025 - 09:34 EAT
This incident affected: Voice.