Phone Network Disruption

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted May 07, 2026 - 14:26 EAT

Investigating

We have alerted Africa's Talking to restore the phone number connectivity with the Telco.
Posted May 07, 2026 - 13:16 EAT
This incident affected: Voice.