Safaricom Network Downtime

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 09:54 EAT

Investigating

We are currently engaging the Telco to have this resolved ASAP.
Posted Mar 14, 2025 - 09:24 EAT
This incident affected: Voice.