Service Access Disruption

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Mar 15, 2026 - 08:48 EAT

Investigating

We are currently investigating this issue.
Posted Mar 14, 2026 - 08:52 EAT
This incident affected: USSD, WhatsApp, Voice, SMS, Zendesk Phone, Odoo Phone, Salesforce Phone, Freshdesk Phone, Zoho Phone, Workflow, Workflow API, Data, and Frontend.