Voice Service Interruption from Africa's Talking

Incident Report for Helloduty

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 10:01 EAT

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 10:00 EAT

Update

We are continuing to investigate this issue.
Posted Oct 28, 2025 - 08:48 EAT

Investigating

We are following up with Africa's Talking to have this issue resolved.
Posted Oct 21, 2025 - 11:16 EAT
This incident affected: Voice.